metadata.yaml - метаданные плагина

Описывает метаданные плгина

authors

Warning

Авторы не должны содержать запятых

authors: ['ilnurgi']

description

Описание плагина

description: Please describe your plugin here

fuel_version

Список версии фуела, которые поддерживает данный плагин

fuel_version: ['8.0']

groups

  • network
  • storage
  • storage::cinder
  • storage::glance
  • hypervisor
  • monitoring
groups: ['storage::cinder']

homepage

homepage: 'http://ilnurgi1.ru'

is_hotpluggable

Включает возможность деплоя данного плагина на уже развернутое окружение

is_hotpluggable: true

licenses

licenses: ['Apache License Version 2.0']

name

Название плагина

name: ilnurgi_plugin

package_version

Версия пакетов плагина, которую использует фуел в работе

package_version: '4.0.0'

releases

Список версии опенстека поддерживаемых плагином

  • deployment_scripts_path - путь к папке со скриптами для деплоя
  • mode - ha|multinode
  • os - название дустрибутива линукс, поддерживаемый плагином
  • repository_path - путь к папке
  • version - версия опенстека, поддерживаемой плагином
releases:
  - os: ubuntu
    version: liberty-8.0
    mode: ['ha']
    deployment_scripts_path: deployment_scripts/
    repository_path: repositories/ubuntu

title

Человекочитаемое название плагина для веба

title: Title for ilnurgi_plugin plugin

version

Версия плагина

version: '1.0.0'